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Starting a New Database 
 

 

1. From the Start menu, open the Microsoft 

Office folder. 

 

2. Choose Microsoft Access 2010 

 

 

 

3. Make sure Blank Database is highlighted 

 

 

4. On the right hand side of the screen: 

 

 

 

 

 

 

 

 

 

 

  

A. Click on the folder and 

choose where you want 

to store your database. 

B. Change the name of 

your database 

C. Click Create 
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Designing a New Database 

 

1. Click on the View option and select Design View 

 

 

 

2. Give your new database table a sensible 

name then click OK. 

 

 

3. Enter your field names and data types. 

 

 

 

 

 

 

 

 

 

4. When all fields have been added, click on the View option and 

select Datasheet View. 

 

 

 

5. Click Yes to save your table. 

  

Type in your field 

names in the Field 

Name column. 

Choose the correct 

data type from the 

Data Type column. 

Fields can be removed by right 

clicking here and selecting Cut. 
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Adding Records (Datasheet View) 

 

In datasheet view, records can be added by simply typing the new details into the first 

available row (beside the *). 

 

 

 

 

 

After you have finished entering a piece of information, it is automatically saved when you 

exit the field. 

 

 

 

Adding Records (Pasting from a spread sheet) 
 

Copy the record data from the spread sheet  

 

[Do not include headings or blank rows, just 

the data you want to insert] 

 

Go back to database and choose data sheet 

view. 

 

 

Click on the first field in the first empty record and choose Paste Append.  
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Adding Validation Rules 

 

1. Click on the View option and select Design View 

 

2. Click on the field to add a validation rule to. 

 

 

 

 

 

Presence Check 

 

 

1. In the General tab, set the Required 

option to Yes. 

 

 

 

 

 

Restricted Choice 

 

 

1. In the Lookup tab, set the Display Control 

option to Combo Box. 

 

2. Set the Row Source Type option to Value 

List 

 

3. In the Row Source option, enter the values 

allowed (separated with a semi colon)  

 

4. Set Limit To List to Yes 
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Length Check 

 

 

1. In the General tab, enter a LEN formula 

into the Validation Rule option. 

 (See the examples of length check rules in 

 the table below) 

 

 

 

LEN( [ISBN]) =17 
Check that the ISBN field is 
exactly 17 characters long 

LEN([Author]) <=20 
Check that the Author field 
contains 20 characters or fewer. 

LEN([Title]) >10 
Check that the Title field contains 
more than 10 characters 

 

 

Range Check 

 

 

1. In the General tab, enter a formula into the 

Validation Rule option. 

 (See the examples of range check rules in the 

 table below) 

 

 

>=10 AND <=20 
Check that the value entered is 
between 10 and 20 

<20 
Check that the value entered is 
below 20 

>50 
Check that the value entered is 
above 50 
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Adding a Picture Field 

 

1. Make sure you have already created a table (page 4). 

 

 

 

2. In the All Access Objects section (left hand side), 

double click on your table. 

 

 

 

 

 

 

 

3. Click on the View option and select Design View 

 

 

 

 

 

4. Add a new field called Picture and select OLE Object as its Data Type. 

 

 

 

 

 

 

 

 

 

5. Click on the View option and select Datasheet View. 

 

 

 

 

 

6. Click Yes to save your table. 
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Creating a Form 
 

1. Make sure you have already created a table containing some fields (page 4) 

 

 

2. Click on the Create tab and choose Form.  

 

 

 

 

 

 

3. Click on the Save icon        and give your form a 

name. 

 

 

 

 

4. You can switch between forms and tables on the left 

hand side of the screen.  
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Adding a Picture (to a Form) 
 

1. Make sure you have already created a table (page 4).  

 

2. Make sure you have already created a picture field (page 8). 

 

3. Make sure you have already created a form (page 9).  

 

 

 

4. Find the picture file you want to include and right click on it. 

 

 

 

5. Choose open with Picture 

Viewer 

 

 

 

 

 

 

6. From the Picture Viewer Edit menu, choose Copy. 

 

 

 

 

 

 

7. Make sure your form is in Form View 

 

 

 

 

 

8. In your database form, right click on the picture field and choose paste. 
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Creating Queries (Searching) 

 

 

1. Make sure you have already created a table (page 4). 

 

 

2. Click on the Create tab and choose Query Design. 

 

 

 

 

 

 

 

3. Click Close without adding any tables 

 

 

 

 

 

 

 

4. From the View menu, select SQL View 

 

 

 

 

 

 

5. Type your query into the space provided. 

 

 

6. Click on the Run button to view the results (check that they are correct). 

 

 

7. Click on the Save icon and give your query a 
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name. 

Creating Queries (Calculations) 
 

1. Make sure you have already created a table (page 4). 

 

2. Click on the Create tab and choose Query Design. 

 

 

 

 

 

3. Highlight your table and click Add, then click Close. 

 

4. Set up your query as follows: 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Click on the Run button to view the results (check that they are correct). 

 

 

Choose the fields you want to 

show. 

Choose the order in which to 

sort your results into  

This example will display the Title, Price, Quantity and Total. 

The Total is calculated automatically by multiplying Price and 

Quantity.  

Results will be in Ascending order of Title. 

This is where you do the 

calculation. Total is the name of 

the field. Abs functions returns a 

value. The fields to use in the 

calculation appear in [] brackets. 
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Click on the Save icon        and give your query a name. 

 

Creating Reports  

 

1. Make sure you have already created a table (page 4). 

 

 

2. Click on the Create tab and choose Report Wizard. 

 

 

 

 

 

3. Choose the table or query you want 

to create the report from. 

 

 

 

4. Use the arrows to select the fields 

to be included in your report 

(double arrow selects all). 

 

 

 

5. Click next twice then change the 

orientation to landscape (keep the 

layout as Tabular 

 

 

 

6. Click next and give your report a 

name, then click finish. 
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Changing Report Layout  

 

1. Open the report you want to edit and click on Design Layout.  

 

 

 

 

 

 

 

 

2. The title can be changed by typing in the label in 

report header section. 

 

 

 

3. Your name can be added by making space in the 

footer section by adjusting the width of the data 

label. 

 

 

 

Click on label and draw a label in the footer. You 

can then type your name into the label. 

 

 

 

4. You can adjust field widths and positions to allow everything to fit onto one page. -

Check that all field boxes are big enough to completely fit the data.  
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Counting Boolean (Yes/No) Fields 

 

A calculated field can be used to count the number of checkboxes that have been checked 

for each record.  

e.g. 

 

 

 

 

 

 

A boolean YES (or checked) counts as -1 and a boolean NO (not checked) counts as 0 using 

the following formula: 

 

 

 

This would produce the following results: 

 

 

 

 

 

To make a YES count a 1 instead of -1 then the Abs (absolute) function should be used as 

follows: 

 

 

 

  

1 here 

2 here 

0 here 
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Creating a User Interface 
 

1. Click on the Create tab and choose Blank Form.  

 

 

 

 

 

 

 

2. Click on the View option and select Design View 

 

 

 

 

 

 

3. Click on the Save icon        and give your switchboard 

form a name. 

 

 

Adding a Title 

 

1. Select the Label tool from the Design menu 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Draw the label onto the blank form 

 

3. Type the title of your switchboard into the label.  
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Inserting an Image 

 

1. Select the Image control from the Design menu 

 

 

 

 

 

 

 

 

2. Draw the picture frame onto your form 

 

 

 

3. Select a picture from file and click Open. 

  

 

 

 

 

Setting Switchboard as Start-up Form 

 

1. From the File menu, choose Options. 

 

 

 

 

 

2. In the Current Database section, change Display Form to your switchboard name. 
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Adding Buttons 

 

1. Select the Button tool from the Design menu 

 

2. Draw the button onto your form 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Next, choose the Category and Action to perform. 

 

Mostly, you will be selecting the Miscellaneous category and either: 

 

• Run Macro  

• Run Query 

 

 

 

 

 

 

 

 

4. Click Next  
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5. Choose the query or macro from the list that you want to attach to the button. 

 

 

 

 

 

 

6. Click Next 

 

7. Select the Text option and type in the text you would like displayed on the button. 

 

 

 

 

 

 

 

8. Click Next 

 

9. Give the button a meaningful name 

 

 

 

 

 

 

 

 

 

 

 

10. Click Finish 
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Creating Macros 
Macros are attached to buttons (page 12). They are used to automatically carry out a task when the 

button is clicked. 

 

1. Click on the Create tab and choose Macro. 

 

 

 

 

 

 

 

2. From the first drop-down, choose OpenForm. 

 

 

 

 

 

 

 

3. Under Form Name, select the form 

you would like to be opened. 

 

 

 

 

 

 

4. Under Data Mode, choose Add or 

Read Only. 

 

 

 

 

 

5. Click on the Save icon        and give your macro a name. 

Add will allow the user to add a 

new record 

Read Only will only allow the 

user to view records. 
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Primary Key (Relational Databases) 
 

Firstly, you must identify a field that will contain a unique entry for each record. This is the 

Primary Key field. 

In this Books database, each book will have a different name so the Title field can be set as 

the key field. 

 

1. Open the table in Design View. 

 

2. Right click on the field you 

want to set as a primary 

key field. 

 

3. Choose Primary Key. 

 

 

 

 

 

 

4. A small key should now 

appear beside the selected 

field to indicate that it is a 

Primary Key.  

 

 

 

 

 

5. Click on the save icon to save your changes. 

 

 

Note:  

The primary key field must now be filled in for every record and each record must 

contain a different value in the field. 
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Linking Tables (Relational Databases) 

 

Firstly you must identify the primary key in the main table and the foreign key in the other 

table. 

 

 

1. Make sure the both tables are not 

currently open. 

 

 

2. From the Database Tools section, 

choose Relationships. 

 

 

 

 

 

 

 

 

 

3. Add both tables then click Close. 

 

 

 

 

 

 

4. Click on the primary key in the 

main table and drag your mouse 

over to the foreign key in the other 

table. 
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5. Tick the box to Enforce 

Referential Integrity. 

 

 

 

6. Click Create. 

 

 

 

 

 

7. A line will now indicate the relationship between the tables (1 to Many). 

 

 

 

 

 

 

 

 

 

 

Note:  

The above example means that every book can have many book sales. 

 

 

8. Click Save. 

 

 

 

 

 

 

The main table will now have a + sign next to each record that links to corresponding 

records in the linked table. 


